Page 5 of 5

Re: Odin's larvae and baby shrimp tank.

PostPosted:04 Jan 2018 08:00
by odin
You too mate!


Sent from my iPhone using Tapatalk Pro

Re: Odin's larvae and baby shrimp tank.

PostPosted:08 Jan 2018 21:25
by odin
Topped off, fed and dosed both with biodigest tonight and after 2 - 2.5 weeks the cloudy bacterial bloom has subsided and life goes on in the baby tank.
Photo 08-01-2018, 21 17 36.jpg

Before:
Photo 20-12-2017, 19 25 01.jpg
After (now):
Photo 08-01-2018, 21 17 23.jpg

Re: Odin's larvae and baby shrimp tank.

PostPosted:09 Jan 2018 06:15
by opae ula related
Nice job!

Re: Odin's larvae and baby shrimp tank.

PostPosted:09 Jan 2018 06:18
by odin
For the record there were no water changes etc, i see other members have this issue sometimes.


Sent from my iPhone using Tapatalk Pro

Re: Odin's larvae and baby shrimp tank.

PostPosted:09 Jan 2018 22:21
by odin
Spotted 7 berried females in the 1st larvae tank tonight... some literally have only 4 eggs and stuff lol.


Sent from my iPhone using Tapatalk Pro

Re: Odin's larvae and baby shrimp tank.

PostPosted:10 Jan 2018 00:55
by Vorteil
Big difference after dosing. I've used biogest before in the past when I started a new tank and every once in awhile I will dose. It's only my 6g that has a sponge filter. The 3g doesn't.

Re: Odin's larvae and baby shrimp tank.

PostPosted:10 Jan 2018 08:10
by odin
Yeah to be honest I dosed with it to keep the water quality good while it seemed to of done a mini cycle from the shrimps growing in size and upping the waste. It’s all caught up now and we had no losses.


Sent from my iPhone using Tapatalk Pro