Opaeula.co.uk

A dedicated forum and online store for the Opae ula shrimp! 

Share photos/videos, journals and logs for your Opae ula tank setups for others to read.
 #7442  by pentux
 21 May 2019 14:56
I feel like getting some MTS to “clean” under the substrate but worry they multiply like yours. Currently have 2 nerites for a year already


Sent from my iPhone using Tapatalk
 #7443  by Algae In Space
 21 May 2019 15:18
pentux wrote: 21 May 2019 14:56 I feel like getting some MTS to “clean” under the substrate but worry they multiply like yours. Currently have 2 nerites for a year already


Sent from my iPhone using Tapatalk

Well until now everything is A-OK! I don't know how much I got in there. Maybe 8. But they are really cute and they don't live that long. They really dig into the substrate! It's a joy to watch.
 #7499  by opae ula related
 26 May 2019 18:54
Algae In Space wrote:Also the berried Opae has lost all eggs but two :huh: let's see if she keeps the two.
Oh no. I think it improves with future pregnancies.
 #7500  by odin
 26 May 2019 19:07
I agree, when the shrimp first become berried they will lose a large amount usually... from my observations anyway.

If you got eggs once you will get them again.


Sent from my iPhone using Tapatalk Pro
 #7502  by odin
 26 May 2019 19:48
I haven’t I’m afraid, sorry... I think we have discussed this on a thread somewhere on here about using a device to blow air through a tube under water to keep the eggs moving and stopping them ‘developing’ mould/die.


Sent from my iPhone using Tapatalk Pro
  • 1
  • 14
  • 15
  • 16
  • 17
  • 18
  • 23